Service down
Monitoring·Full outage

We would like to inform you that following the recent large-scale outage of Google Cloud services, which our servers rely on, we are gradually restoring full operations.

The overall functionality of our service has been recovered, and we continue to monitor and stabilize the system. However, you may still encounter occasional errors in some areas as we complete the recovery process.

We sincerely appreciate your patience and understanding during this time. Our team is working diligently to ensure everything returns to normal as quickly as possible.

If you experience any issues, please do not hesitate to reach out to our support team.

Thu, Jun 12, 2025, 09:03 PM
(1 day ago)
·
Affected components
Website
API
Updates

Monitoring

We would like to inform you that following the recent large-scale outage of Google Cloud services, which our servers rely on, we are gradually restoring full operations.

The overall functionality of our service has been recovered, and we continue to monitor and stabilize the system. However, you may still encounter occasional errors in some areas as we complete the recovery process.

We sincerely appreciate your patience and understanding during this time. Our team is working diligently to ensure everything returns to normal as quickly as possible.

If you experience any issues, please do not hesitate to reach out to our support team.

Thu, Jun 12, 2025, 09:03 PM

Identified

Promised update: the issue with Google has turned out to be widespread. It has affected not only our service, but also major Google products (including YouTube, Drive, Gmail, Maps, and Cloud), as well as services from other companies like Discord, Twitch, Spotify, Amazon Web Services, Cloudflare, DoorDash and many more.

Thu, Jun 12, 2025, 06:48 PM(2 hours earlier)

Investigating

We are currently experiencing an issue with Google Cloud Platform that is preventing access to our servers. Our team is actively investigating the root cause and working to resolve the situation as quickly as possible.

We will provide an update as soon as we have more information. We expect to share further details within approximately 20 minutes.

Thank you for your patience and understanding.

Thu, Jun 12, 2025, 06:22 PM(26 minutes earlier)

Monitoring

Issue has been resolved. We will continue to monitoring situation.

Sun, Apr 27, 2025, 07:49 AM(1 month earlier)

Investigating

We see that all our service is not available. Currently investigating problem.

Sun, Apr 27, 2025, 06:37 AM(1 hour earlier)
Powered by